Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайты «1С-Рарус» используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности rarus.ru и применением этих технологий.
Продолжив использование веб-сайтов «1С-Рарус», Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности.
Интернет-магазин Доставка

Мы выбрали для Вас офис в Москве.

Вы можете изменить его на офис в другом городе.

Михаил Волков (Все сообщения пользователя)

Внимание! Данный форум является модерируемым.
Для получения к нему доступа необходимо зарегистрироваться или авторизоваться на сайте.

  1. Форум
  2.  / Пользователи
  3.  / Михаил Волков
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 15 След.
Альфа-авто ААА и УФ
 
[QUOTE]Данил Василига написал:
Надеюсь, 1С-РАРУС пересмотрит условия апгрейда.[/QUOTE]
Что долгожданная редакция 6 Альфа-Авто уже готова? Где можно ознакомиться с условиями апгрейда с 4.1?
Пожелания к будущим релизам Альфа-Авто ред. 6
 
[QUOTE]Владимир Гаврилов написал:
какой обмен Альфа-Авто Вы имеете ввиду?[/QUOTE]
[QUOTE]Данил Василига написал:
Реализовать обмен с 1С:Бухгалтерией через план обмена, как это сделано в типовых конфигурациях 1С.[/QUOTE]
И не только с БП3, например, с КА2.4 (ERP).
Пожелания к будущим релизам Альфа-Авто ред. 6
 
[QUOTE]Владимир Гаврилов написал:
Пожелания зафиксировали.[/QUOTE]
Планируется ли обмен Альфа-Авто через универсальный формат EnterpriseData (КД3)?
Платформа 8.3.12.1685
 
[QUOTE]Данил Василига написал:
В соседнем автосалоне под windows 2016 тоже были проблемы на платформе выше 8.3.10[/QUOTE]
Дело сейчас не ОС, и даже не в номере релиза платформы, а ее [URL=https://rarus.ru/forum/messages/forum7/topic13628/message83074/#message83074]разрядности[/URL]. По любому для других последних конфигураций надо ставить (и поставил) 2-ю новую (более высокую) 64-битную платформу. А вот с Com-обменами между базами 1С, работающих на разных платформах, у меня проблема: Возможно ли в консоли Службы компонентов создать обертку OLE соединения V83.Application?
Платформа 8.3.12.1685
 
[QUOTE]Данил Василига написал:
В windows 2008 R2 работает, windows 2019 - не работает торговое оборудование.[/QUOTE]
[QUOTE]Данил Василига [URL=https://rarus.ru/forum/messages/forum7/topic9849/message83878/#message83878]написал[/URL]:
В windows 2008 R2 с платформой 8.3.12.1685 проблем не было, режим совместимости был...
Сотрудники РАРУСа же писали, что в windows 10 имеются проблемы, а windows 2019 - ее серверный аналог.[/QUOTE]
Выходит, что требование [URL=https://rarus.ru/forum/messages/forum7/topic13628/message82364/#message82364]Не выше 8.3.10[/URL] только для windows 10 (сервер 2019)? Замечу, что последние релизы 8.2 конфигураций: [URL=https://forum.mista.ru/topic.php?id=840303]УТ10.3[/URL], [URL=https://forum.mista.ru/topic.php?id=840299]УПП[/URL] тоже требуют платформу не ниже 8.3.12 (в режиме совместимости "Версия 8.2.13", если не Windows 10). Но это требование вызвано [URL=https://infostart.ru/journal/news/mir-1s/1s-zakrepila-razdelenie-platformennykh-litsenziy-na-prof-i-korp_1002294/]разделением платформенных лицензий на ПРОФ и КОРП[/URL] (возможно следующим шагом 1С будет запрет на использование платформ ниже 8.3.12).
Но требование [URL=https://rarus.ru/forum/messages/forum7/topic13628/message82364/#message82364]Не выше 8.3.10[/URL] не единственное ограничение Альфа-Авто, еще разрядность платформы: должна быть [URL=https://rarus.ru/forum/messages/forum7/topic13628/message83074/#message83074]32-битная[/URL] (хотя бы клиентская часть), иначе [URL=https://rarus.ru/forum/messages/forum7/topic11558/message83055/#message83055]Сервер защиты не работает[/URL]. А последние 8.3 конфигурации (например, КА2.4, ERP) требуют полностью 64-битную платформу. Приходится для Альфа-Авто оставлять не выше 8.3.10 платформу, и для других добавлять новую (более высокую) 64-битную платформу.
Добавить 2-ю 8.3 платформу не проблема: [URL=https://fakirss.wordpress.com/2016/10/24/%D0%B0%D0%BB%D0%B3%D0%BE%D1%80%D0%B8%D1%82%D0%BC-%D1%83%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BA%D0%B8-%D0%BD%D0%B5%D1%81%D0%BA%D0%BE%D0%BB%D1%8C%D0%BA%D0%B8%D1%85-%D1%80%D0%B5%D0%BB%D0%B8%D0%B7/]Алгоритм установки нескольких релизов сервера 1С 8.3 на одну машину[/URL], проблема в том, что Com-обмены между базами 1С, работающих на разных платформах рухнули. Попалась одна статья [URL=https://infostart.ru/public/610960/]COM соединения с базами 1С на различных версиях платформы "Без перерегистрации и СМС"[/URL]. По ней создал обертку COM соединения V83.COMConnector, но она меня не устраивает: с ограниченными возможностями, запускается небольшая серверная часть.
Возможно ли в консоли Службы компонентов (раньше ею не занимался) создать обертку OLE соединения V83.Application, или перенастроить имеющуюся COM соединения V83.COMConnector?
Работа с оборудованием запрещена
 
[QUOTE]Данил Василига написал:
В windows 2008 R2 с платформой 8.3.12.1685 проблем не было, режим совместимости был...
Сотрудники РАРУСа же писали, что в windows 10 имеются проблемы, а windows 2019 - ее серверный аналог.[/QUOTE]
Выходит, что требование [URL=https://rarus.ru/forum/messages/forum7/topic13628/message82364/#message82364]Не выше 8.3.10[/URL] только для windows 10 (сервер 2019)? ([URL=https://rarus.ru/forum/messages/forum7/topic13460/message81181/#message81181]Платформа 8.3.12[/URL])
Пробитие чеков за автомобиль
 
[QUOTE]Александр Мещеряков написал:
а где вы ее взяли?[/QUOTE]
Может эта: [URL=https://rarus.ru/forum/messages/forum7/topic13797/message83847/#message83847]Инструкция по работе с чеками онлайн касс в конфигурации Альфа-Авто ред.5[/URL]
Пробитие чеков за автомобиль
 
[QUOTE]Антон Ильясов написал:
Больная тема по продаже в одном чеке подакцизных товаров (моторного масла) и товаров и услуг. Надо разделять это на несколько чеков, т.к. у нас это на разных системах налогообложения.[/QUOTE]
[QUOTE]Данил Василига написал:
Если я "научу" программу делить чеки и поделюсь с Вами доработкой...[/QUOTE]

Конечно выкладывай, но не в эту тему (при чем здесь Пробитие чеков за автомобиль)
Работа с оборудованием запрещена
 
[QUOTE]Иван Булхов написал:
Какой? У меня 1C Предприятие (8.3.12.1714)[/QUOTE]
[URL=https://rarus.ru/forum/messages/forum7/topic13628/message82364/#message82364]Не выше 8.3.10[/URL], при чем [URL=https://rarus.ru/forum/messages/forum7/topic13628/message83074/#message83074]32-битная[/URL] (хотя бы клиентская часть). Проблем с печатью и торговым оборудованием, а так же с [URL=https://rarus.ru/forum/messages/forum7/topic13628/message82361/#message82361]Фронт кассира[/URL] не замечали?
[QUOTE]Данил Василига написал:
до перехода на новую версию windows у нас была платформа 8.3.12 на windows server 2008 R2. На платформе 8.3.12 на windows 2019 у нас наблюдались проблемы с печатью и торговым оборудованием.[/QUOTE]
Не понял, а на windows server 2008 R2 платформе 8.3.12 этих проблем не наблюдалось? По точнее бы релиз 8.3.12 (и новой платформы), если использовали ли режим совместимости, то какой?
Онлайн кассы
 
[QUOTE]netservice написал:
При печати из ЗаказНаряда выбираем ОплатаКартой, в чеке выходит Наличными[/QUOTE]
Все же [URL=https://rarus.ru/forum/messages/forum7/topic4554/message83355/#message83355]Рекомендую использовать наименование данной настройки "ПЛАТ. КАРТА"[/URL].
Онлайн кассы
 
[QUOTE]Skrepka Skrepka написал:
для бухгалтерии и ЗУПа мне нужна новая платформа, а для Альфы древняя?[/QUOTE]
Последние релизы 8.2 конфигураций: [URL=https://forum.mista.ru/topic.php?id=840303]УТ10.3[/URL], [URL=https://forum.mista.ru/topic.php?id=840299]УПП[/URL] тоже требуют платформу не ниже 8.3.12 (в режиме совместимости "Версия 8.2.13", если не Windows 10).
Онлайн кассы
 
Добрый день. У нас случилась неприятность: онлайн-касса АТОЛ 11Ф перестала работать из-за того, что у нас установлена полная (платная) версия драйверов ККТ АТОЛ, для которой нужна лицензия, и "...выберете в утилите "Управления драйверами" бесплатный вариант библиотеки драйвера" (полный текст ошибки приведен ниже на 3-й картинке АльфаАвтоВерсияДрайвераККТ). Сисадмин выполнил это, установил бесплатную версию (см. ниже 1-ю картинку УправлениеДрайверамиККТ), проверил, связь есть, касса работает (см. ниже 2-ю картинку ТестДрайверККТ). Но при включении Альфа-Авто, перед (или в начале) процесса "Подключение предоставляемого оборудования" версия драйверов ККТ меняется на полную (платную) с последующими ошибками. Неужели это делает сама Альфа-Авто (или СЗиУО), как предотвратить это переключение?
Изменено: Михаил Волков - 27.06.2019 13:18:14
Оплата платежными картами
 
[QUOTE]Александр Демченко написал:
к сожалению во фронте кассира вид оплаты платежной карты не появляется, в чем может быть причина?[/QUOTE]
Возможно в этом: [URL=https://rarus.ru/forum/messages/forum7/topic4554/message74129/#message74129]Рекомендую использовать наименование данной настройки "ПЛАТ. КАРТА"[/URL].
Оплата по безналу, Не можем настроить эквайринг, нет пункта "Оплата картой"
 
[QUOTE]Руслан Смирнов написал:
В настройках ФР указан пункт ПЛАТ.КАРТА, в настройках самой 1С так же есть пункт ПЛАТ.КАРТА. По инструкции, которую я нашел на форумах, все сделали.[/QUOTE]
У Вас пробел отсутствует "[B]ПЛАТ. КАРТА[/B]". Эта ошибка тянется [URL=https://rarus.ru/forum/messages/forum7/topic4554/message72572/#message72572]с времен Альфа-Альфа 4.1[/URL].
Онлайн кассы
 
Вчера не было продаж, точнее была попытка, даже чек отбили, но клиент отказался. Пришлось еще возвратный чек отбить. А при закрытии смены ФР АТОЛ 11Ф ошибку выдал: [B]Неверная цена (сумма)[/B]!? Неужели разработчики АТОЛ не предусмотрели такой ситуации: нулевую сумму сочли неверной?
Подскажите: принудительно закрыть смену на ФР (без Тест драйвера ККТ) пользователи могут во Фронте кассира на вкладке КАССА по кнопке Z-отчет?
Фронт кассира 1С Альфа-Авто
 
[QUOTE]Светлана Сулименко написал:
только 32битная платформа может регистрировать внешнюю компоненту.[/QUOTE]
Печально... если Альфа-Авто и будет работать на платформе выше 8.3.10, но на 32-битной. А для БП3.0, ЗуП3.1, КА2.4 (ERP) желательно 64-битную.
Альфа-Авто 4,1 и ККМ онлайн
 
[QUOTE]Светлана Сулименко написал:
мы не гарантируем корректную работу АА4,1 на 8,3[/QUOTE]
Спасибо за [URL=https://rarus.ru/forum/messages/forum7/topic13628/message83061/#message83061]ответ[/URL]...
Фронт кассира 1С Альфа-Авто
 
[QUOTE]Светлана Сулименко написал:
проблема у Вас из-за того, что платформа не 32битная. а только данная версия может регистрировать внешнюю компоненту[/QUOTE]
Это и для Альфа-Авто 5.1 так? (планируем переход на нее, 6-й похоже не дождаться)
Альфа-Авто 4,1 и ККМ онлайн
 
[QUOTE]Светлана Сулименко написал:
для АА4,1 используется только платформа 8,2 (8,2,19,130), платформа 8,3 нами не заявлена для работы с АА4,1[/QUOTE]
Да, под 8.2 нет проблемы с сервером защиты. Но Альфа-Авто 4.1 работала на платформе 8.3.10.2466 только установленной с 2-х дистрибутивов: [URL=https://releases.1c.ru/version_file?nick=Platform83&ver=8.3.10.2466&path=Platform\8_3_10_2466\windows.rar]Технологическая платформа 1С:Предприятия для Windows[/URL](i386) и [URL=https://releases.1c.ru/version_file?nick=Platform83&ver=8.3.10.2466&path=Platform\8_3_10_2466\windows64.rar]Cервер 1С:Предприятия (64-bit) для Windows[/URL] (x86_64)!?
Фронт кассира 1С Альфа-Авто
 
[QUOTE]Светлана Сулименко написал:
Альфа-Авто пока не работает на платформе выше чем 8,3,10.[/QUOTE]
А зависит ли с какого дистрибутива устанавливать платформу для ОС х64? Раньше (как для 8.2) устанавливал с 2-х дистрибутивов: [URL=https://releases.1c.ru/version_file?nick=Platform83&ver=8.3.10.2466&path=Platform\8_3_10_2466\windows.rar]Технологическая платформа 1С:Предприятия для Windows[/URL] (i386) и [URL=https://releases.1c.ru/version_file?nick=Platform83&ver=8.3.10.2466&path=Platform\8_3_10_2466\windows64.rar]Cервер 1С:Предприятия (64-bit) для Windows[/URL] (x86_64). А теперь с [URL=https://releases.1c.ru/version_file?nick=Platform83&ver=8.3.10.2466&path=Platform\8_3_10_2466\windows64full.rar]Технологическая платформа 1С:Предприятия (64-bit) для Windows[/URL], и возникла [URL=https://rarus.ru/forum/messages/forum7/topic11558/message83055/#message83055]проблема с сервером защиты[/URL].
Альфа-Авто 4,1 и ККМ онлайн
 
Переустановил платформу 8.3.10.2466 с дистрибутива Технологическая платформа 1С:Предприятия (64-bit) для Windows (не с 2-х как раньше). Возникла ошибка: Не удалось загрузить компоненту C:\ProgramData\Protect\LocalProtect\V8AutoSalon.dll.
Переустановил сервер защиты, но ошибка осталась. Что нужно сделать, чтобы ее устранить?
Фронт кассира 1С Альфа-Авто
 
[QUOTE]Светлана Сулименко написал:
Алексей, возможно в релизе 5,1,16 будет реализована данная возможность, но точной информации пока нет.[/QUOTE]
Наверное не скоро... В былые времена стояли по несколько 1С-серверов (точнее служб 1C:Enterprise 8.3 Server Agent (x86-64)) на одном сервере разных версий: 8.1, 8.2, 8.3. А тут версия одна 8.3 только релизы разные: 8.3.10 и 8.3.14 - не так просто!? У кого есть опыт установки 1С-серверов одной версии 8.3, но разных релизов, поделитесь..?
Фронт кассира 1С Альфа-Авто
 
[QUOTE]Алексей Федулеев написал:
на сервере работает не только Альфа, но и Бухгалтерия, Зарплата, а там минимальная версия платформы начинается с 8.3.12...[/QUOTE]
А в них работает поиск по символам введенных с клавиатуры? Если нет, и не будет устранен этот дефект для новых платформ, то придется на сервере держать несколько платформ: 8.3.10 для Альфа-Авто, 8.3.12 и выше для остальных конфигураций (как когда-то 8.2 и 8.3). Скорее этот вопрос к 1С, чем 1С-Рарус.
Изменено: Михаил Волков - 11.04.2019 08:13:42 (Добавление текста)
Фронт кассира 1С Альфа-Авто
 
[QUOTE]Алексей Федулеев написал:
обновил платформу 1С до версии 8.3.12.1855, после обновления в Альфа-Авто... перестал работать поиск по Артикулу с клавиатуры[/QUOTE]
И в более ранних версиях платформ 8.3.12 перестал работать поиск по символам введенных с клавиатуры. Вроде как [URL=https://forum.mista.ru/topic.php?id=830635#41]специально[/URL]!?
Фискальный признак документа (ФПД), Получение ФПД для отправки чека в электронном виде.
 
[QUOTE]Михаил Волков написал:
Другие значения SafeArrayПараметрыЧека.GetValue(x, y) проверяли, существуют? [/QUOTE]
Нет, но их можно добавить в обработке Торговое оборудование. У меня ФР АТОЛ, поэтому доработал функцию и процедуру формы ФР_Атол_ДрайверФР следующим образом:[CODE]// Получить параметры чека
Функция ПолучитьПараметрыЧека(НомерСмены,НомерЧека,НомерДок,ДатаЧека,Фискальный = Истина,НомерФПД = ""); //+МВ 27.03.2019

// Сохраняем номер,дату и время чека
Устройство.ПолучитьСостояние();
КодОшибки = РезультатВыполненияДействия(); Если КодОшибки <> 0 Тогда Возврат КодОшибки; КонецЕсли;

ПроверкаПоддержки54ФЗ();

Если Поддерживает54ФЗ Тогда

Устройство.НомерРегистра = 53;
КодОшибки = ВыполнитьКоманду("ПолучитьРегистр");
Если КодОшибки <>0 Тогда Возврат КодОшибки; КонецЕсли;

// Получим номер смены
НомерСмены = -1;
НомерСмены = Число(Устройство.Смена);
Если НомерСмены=0 Тогда НомерСмены=-1;  КонецЕсли;

Если Фискальный Тогда
НомерЧека = Устройство.КоличествоИтераций;
Если НомерЧека=0 Тогда НомерЧека=-1;  КонецЕсли;
Устройство.НомерРегистра = 52;
КодОшибки = ВыполнитьКоманду("ПолучитьРегистр");
Если КодОшибки <>0 Тогда Возврат КодОшибки; КонецЕсли;
НомерДок  = Устройство.НомерДокумента;

//+МВ 27.03.2019 Получим фискальный признак
НомерФПД = Устройство.ФискальныйПризнак;
Иначе
НомерДок = Устройство.НомерЧека - 1;
КонецЕсли;
Иначе

// Сохраняем номер чека
Устройство.ПолучитьСостояние();
КодОшибки = РезультатВыполненияДействия(); Если КодОшибки <> 0 Тогда Возврат КодОшибки; КонецЕсли;

Устройство.НомерРегистра = 19;
КодОшибки = ВыполнитьКоманду("ПолучитьРегистр");
Если КодОшибки <>0 Тогда Возврат КодОшибки; КонецЕсли;

НомерЧека = Устройство.НомерЧека-1;
НомерДок  = Устройство.НомерДокумента-1;

// Получим номер закрытой смены
НомерСмены = -1;
Устройство.НомерРегистра = 21; // номер текущей смены
КодОшибки = ВыполнитьКоманду("ПолучитьРегистр");
Если КодОшибки <>0 Тогда Возврат КодОшибки; КонецЕсли;

НомерСмены = Число(Устройство.Смена);
Если НомерСмены=0 Тогда НомерСмены=-1;  КонецЕсли;

КонецЕсли;

// Сохраняем дату и время чека
ДатаЧека=Формат(Устройство.Год,"ЧЦ=4; ЧВН=; ЧГ=0")+"."+
Формат(Устройство.Месяц,"ЧЦ=2; ЧВН=; ЧГ=0")+"."+
Формат(Устройство.День,"ЧЦ=2; ЧВН=; ЧГ=0")+" "+
Формат(Устройство.Час,"ЧЦ=2; ЧВН=; ЧГ=0")+":"+
Формат(Устройство.Минута,"ЧЦ=2; ЧВН=; ЧГ=0")+":"+
Формат(Устройство.Секунда,"ЧЦ=2; ЧВН=; ЧГ=0");
Возврат 0;

КонецФункции

// Вернуть параметры чека
Процедура ВернутьПараметрыЧека(НомерСмены,НомерЧека,НомерДок,ДатаЧека,НомерФПД) //+МВ 27.03.2019
// Возвращает данные пробитого на ФР чека
// .. НомерЧека = Число(<Номер пробитого чека>)
// .. ДатаЧека = Дата(<Дата пробитого чека>)
ПараметрыВозврата=Рарус_Компонента.СоздатьПараметры(5,1); //+МВ 27.03.2019
ПараметрыВозврата.SetValue(0,0,НомерСмены);
ПараметрыВозврата.SetValue(1,0,НомерЧека);
ПараметрыВозврата.SetValue(2,0,НомерДок);
ПараметрыВозврата.SetValue(3,0,ДатаЧека);
ПараметрыВозврата.SetValue(4,0,НомерФПД); //+МВ 27.03.2019
КонецПроцедуры // ВернутьПараметрыЧека[/CODE]Далее добавил в документ ЧекНаОплату и обработку ФронтКассира реквизит НомерФПД (тип Строка 10) - Фискальный признак документа. И дописал [URL=https://rarus.ru/forum/messages/forum7/topic12988/message82204/#message82204]в выше упомянутый код[/URL] ФронтКассира следующее:[CODE]Попытка
КоличествоСтрок=0; КоличествоСтолбцов=0;
SafeArrayПараметрыЧека.GetBounds(КоличествоСтрок,КоличествоСтолбцов);
НомерСмены=Число(SafeArrayПараметрыЧека.GetValue(0,0));
НомерЧека=Число(SafeArrayПараметрыЧека.GetValue(1,0));
ДатаФР=Вычислить("'"+SafeArrayПараметрыЧека.GetValue(3,0)+"'");
НомерДокумента=Число(SafeArrayПараметрыЧека.GetValue(2,0));
НомерФПД = ""; //+МВ 27.03.2019  
Если КоличествоСтрок > 4 Тогда
НомерФПД = СокрЛП(SafeArrayПараметрыЧека.GetValue(4,0));
КонецЕсли;
СтруктураВозвратныхПараметров = Новый Структура("ДатаФР,НомерЧека,НомерДокумента,НомерСмены,НомерФПД",ДатаФР,НомерЧека,НомерДокумента,НомерСмены,НомерФПД); //-МВ
Исключение
ТекстОшибки="Ошибка получения фискальных реквизитов пробитого чека: "+ОписаниеОшибки();
КонецПопытки;[/CODE]А в функцию ЗаписатьЧек():[CODE]Функция ЗаписатьЧек(ФлагПроведения,СообщениеОбОшибке,ПраваДополнительно=НЕОПРЕДЕЛЕНО, КПопыток=-1, ПроверитьКорректность=ЛОЖЬ) Экспорт
Результат=ЛОЖЬ;

// Сформируем и заполним объект для записи в БД
Если ХозОперация=Справочники.ХозОперации.ПриходныйКассовыйОрдер ИЛИ (НЕ УстановленРежим("РКО") И ХозОперация=Справочники.ХозОперации.РасходныйКассовыйОрдер) Тогда
ДокументОбъект = Ссылка.ПолучитьОбъект();
ЗаполнитьЗначенияСвойств(ДокументОбъект, ЭтотОбъект, "НомерЧека,ДатаФР,НомерДокумента,НомерСмены,ФР,КассаККМ,СкладКомпании");
ИначеЕсли ХозОперация=Справочники.ХозОперации.ЧекНаОплату И (НЕ Ссылка.Пустая()) Тогда
ДокументОбъект = Ссылка.ПолучитьОбъект();
ДокументОбъект.Оплаты.Загрузить(Оплаты.Выгрузить());
ЗаполнитьЗначенияСвойств(ДокументОбъект, ЭтотОбъект, "НомерЧека,ДатаФР,НомерДокумента,НомерСмены,ФР,КассаККМ,СкладКомпании,ПолученоНал,ПолученоБезНал,НомерФПД"); //+МВ 27.03.2019
Попытка ДокументОбъект.АвтоЗакрытиеСделок = ЭтотОбъект.ДоговорВзаиморасчетов.АвтоЗакрытиеСделок; Исключение КонецПопытки;
ДокументОбъект.Дата=ТекущаяДата();[/CODE]В форме документа ЧекНаОплату реквизит НомерФПД расположил на вкладке Фискальные реквизиты в виде гиперссылки, при нажатии на которую открывается чек на сайте ОФД:[CODE]// Открыть чек на сайте ОФД Такском-Касса
//+МВ 29.03.2019
Процедура НомерФПДНажатие(Элемент)
Если ПустаяСтрока(НомерФПД) Тогда Возврат; КонецЕсли;
ЗапуститьПриложение("https://receipt.taxcom.ru/v01/show?fp=" + СокрЛП(НомерФПД) + "&s=" + Формат(СуммаДокумента,"ЧГ=0") + "&sf=False&sfn=False");
КонецПроцедуры[/CODE]Таким образом всегда можно убедиться ушел ли чек в ОФД.
Изменено: Михаил Волков - 30.03.2019 15:20:46 (Добавление текста)
Страницы: 1 2 3 4 5 6 7 8 9 10 11 ... 15 След.
Услуги «1С» для малого и среднего бизнеса
Заинтересованы в сотрудничестве?
Нужна консультация?
Свяжитесь с нами!
Заказать обратный звонок
1c@rarus.ru
Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб‑сайты «1С‑Рарус» используют технологию cookie и аналогичные. Продолжив использование наших веб‑сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности rarus.ru и применением этих технологий.
Продолжив использование веб‑сайтов «1С‑Рарус», Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности.
Facebook Vkontakte Youtube Instagram