Интернет-магазин Доставка

Мы выбрали для Вас офис в Москве.

Вы можете изменить его на офис в другом городе.

Олег Ким (Все сообщения пользователя)

Внимание! Данный форум является модерируемым.
Для получения к нему доступа необходимо зарегистрироваться или авторизоваться на сайте.

  1. Форум
  2.  / Пользователи
  3.  / Олег Ким
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1
Онлайн кассы
 
[QUOTE]Михаил Новохатько написал:
Находите строки в модуле объекта обработки фронт кассира и заменяете на эти строки:

// Определим вид выписки (расход/приход) и если указаны возвраты, то возврат
ЭтоРасходВыписки = Ложь;
ВозвратПоВыписке = Истина;

Если ТипЗнч(Ссылка) = Тип("ДокументСсылка.Выписка") Тогда

ЭтоРасходВыписки = (Ссылка.СуммаДокументаРасход <> 0 ИЛИ Ссылка.СтатьяДДС.ВидДвижения=Перечисления.ВидыДвижений.Расход);
Если Не ЭтоРасходВыписки ТОгда
ВозвратПоВыписке = Ложь;
КонецЕсли; //моё
//Для Каждого ТекущаяСтрока Из Ссылка.Состав Цикл
// Если НЕ ЗначениеЗаполнено(ТекущаяСтрока.Сделка) ИЛИ
// ЭтоРасходВыписки И ДокументыВозвратаРасхода.Найти(ТипЗнч(ТекущаяСтрока.Сделка)) = Неопределено ИЛИ
// НЕ ЭтоРасходВыписки И ДокументыВозвратаПрихода.Найти(ТипЗнч(ТекущаяСтрока.Сделка)) = Неопределено Тогда
// ВозвратПоВыписке = Ложь;
// Прервать;
// КонецЕсли;
//КонецЦикла;
//
КонецЕсли;[/QUOTE]
Михаил, я правильно понимаю, что этот код отрабатывает в случае создания отдельного документа строки банковской выписки без документа расхода?
Онлайн кассы
 
[QUOTE]Михаил Новохатько написал:
Находите строки в модуле объекта обработки фронт кассира и заменяете на эти строки:

// Определим вид выписки (расход/приход) и если указаны возвраты, то возврат
ЭтоРасходВыписки = Ложь;
ВозвратПоВыписке = Истина;

Если ТипЗнч(Ссылка) = Тип("ДокументСсылка.Выписка") Тогда

ЭтоРасходВыписки = (Ссылка.СуммаДокументаРасход <> 0 ИЛИ Ссылка.СтатьяДДС.ВидДвижения=Перечисления.ВидыДвижений.Расход);
Если Не ЭтоРасходВыписки ТОгда
ВозвратПоВыписке = Ложь;
КонецЕсли; //моё
//Для Каждого ТекущаяСтрока Из Ссылка.Состав Цикл
// Если НЕ ЗначениеЗаполнено(ТекущаяСтрока.Сделка) ИЛИ
// ЭтоРасходВыписки И ДокументыВозвратаРасхода.Найти(ТипЗнч(ТекущаяСтрока.Сделка)) = Неопределено ИЛИ
// НЕ ЭтоРасходВыписки И ДокументыВозвратаПрихода.Найти(ТипЗнч(ТекущаяСтрока.Сделка)) = Неопределено Тогда
// ВозвратПоВыписке = Ложь;
// Прервать;
// КонецЕсли;
//КонецЦикла;
//
КонецЕсли[/QUOTE]
Михаил, спасибо вам!
Будете в Питере - с  меня пиво!
Онлайн кассы
 
[QUOTE]Светлана Сулименко написал:
[URL=/forum/user/66658/]Олег Ким[/URL], а вот это будет реализовано в будущем 5,1,17[/QUOTE]
Т.е. до выхода версии 5.1.17 единственный вариант - создавать документ реализации, прикреплять поступившую оплату, на основании реализации делать возврат,  и потом формировать строку банковской выписки с расходом и документов возврата?
Онлайн кассы
 
[QUOTE]Светлана Сулименко написал:
[URL=/forum/user/66658/]Олег Ким[/URL], а вот это будет реализовано в будущем 5,1,17[/QUOTE]
Т.е. до выхода 5.1.17 клиенты так и будут платить штрафы, если хотят остаться на типовой?
Онлайн кассы
 
[QUOTE]Светлана Сулименко написал:
[URL=/forum/user/66658/]Олег Ким[/URL], если Вам нужно вернуть деньги, которые оплатил клиент, то у Вас же будет какой-то возвратный документ? например, возврат товаров от покупателя, так? [/QUOTE]
Мы сейчас ходим кругами, у нас ситуация аналогичная той, что я привел в первой цитате, и вы же там писали, что это не реализовано и нужно ждать обновления, мой первый вопрос и был о том, когда стоит ждать обновления.
Онлайн кассы
 
[QUOTE]Светлана Сулименко написал:
[URL=/forum/user/66658/]Олег Ким[/URL], если Вам нужно вернуть деньги, которые оплатил клиент, то у Вас же будет какой-то возвратный документ? например, возврат товаров от покупателя, так? [/QUOTE]
Клиент внес предоплату, у нас нет ничего кроме строки банковской выписки в системе, как пробить чек с видом "Возврат прихода?
Онлайн кассы
 
[QUOTE]Светлана Сулименко написал:
[URL=/forum/user/66658/]Олег Ким[/URL], сроков выхода релиза пока нет

чек возврата прихода из Банковской выписки можно распечатать при указании возвратной  сделки[/QUOTE]
Есть строка банковской выписки с приходом от клиента, в какой последовательности нужно ввести документы, чтобы получить чек с видом возврат прихода?
Онлайн кассы
 
[QUOTE]Светлана Сулименко написал:
[URL=/forum/user/16491/]Юлия Насонова[/URL], данная возможность будет в будущем релизе Альфа-Авто[/QUOTE]
Доброе утро!

Известны сроки выхода будущего релиза? Два месяца прошло, чек возврата прихода из банковской выписки так и не распечатать.

Спасибо!
альфа авто 4.1.01.30 переход на ФФД 1.05, Добрый день! Подскажие пожалуйста, ЦТОшник заменил фискальный накопитель, обновил прошивку в штрих м 02ф, соответсвенно ккм стал работать в формате ФФД 1.05, а
 
[QUOTE]Светлана Рожок написал:
[QUOTE] Антон Яшин написал:
Т.е. несмотря на то что в 4 альфе в отличии от 5 не было релиза в котором явно была бы указанна поддержка офд 1.05. все должно работать?\   21.12.2017 09:56:30 "Вышел новый релиз ПП "Альфа-Авто:  Автосалон+Автосервис+Автозапчасти ПРОФ, редакция 5.1" (5.1.13.04)

Новое в релизе:

Добавлена поддержка ОФД 1.05."[/QUOTE]
В конфигурацию Альфа-авто ред. 4 не добавлена полноценная поддержка ФФД 1.05, но добавлена поддержка ККТ нового поколения с передачей данных онлайн в соответствии с законом 54-ФЗ.
Поэтому новые кассы можно подключить и пробивать обычные чеки продажи и оплаты. Не поддерживается функционал с пробитием чеков с авансами, предоплатами и постоплатами.[/QUOTE]
Добрый день!

Планируется ли добавить поддержку ФФД 1.05 в Альфа-авто ред 4 в ближайшее время?
Если нет, то есть ли у вас алгоритм доработки типовой 4.1.01.30 с учетом реализованного функционала в версии 5.1.13.04?

Спасибо!
Страницы: 1
Услуги «1С» для малого и среднего бизнеса
Заинтересованы в сотрудничестве?
Нужна консультация?
Свяжитесь с нами!
Заказать обратный звонок
1c@rarus.ru
Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб‑сайты «1С‑Рарус» используют технологию cookie и аналогичные. Продолжив использование наших веб‑сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности rarus.ru и применением этих технологий.
Продолжив использование веб‑сайтов «1С‑Рарус», Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности.
Facebook Vkontakte Youtube Instagram